Announcement

Collapse
No announcement yet.

CRTPF RCDLEN limitation

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • CRTPF RCDLEN limitation

    I need to change the RCDLEN parameter in a CLLE program that creates a flat file in QTEMP so that the record length is around 200,000. Currently, it is 20,000 and I get a syntax error if I try to change it much >= 40,000. Any idea why the limit and how to bypass it. Currently, I have the program use the *SYSRPYL to automatically answer the file full message?

    Code:
    Create Physical File (CRTPF)
    
    Type choices, press Enter.
    
    Label . . . . . . . . . . . . .
    File . . . . . . . . . . . . . . FILE > CRMPDELIM
    Library . . . . . . . . . . . > QTEMP
    Source file . . . . . . . . . . SRCFILE QDDSSRC
    Library . . . . . . . . . . . *LIBL
    Source member . . . . . . . . . SRCMBR *FILE
    Record length, if no DDS . . . . RCDLEN > 40000
    Generation severity level . . . GENLVL 20
    Flagging severity level . . . . FLAG 0
    File type . . . . . . . . . . . FILETYPE *DATA
    Member, if desired . . . . . . . MBR *FILE
    User specified DBCS data . . . . IGCDTA *NO
    Text 'description' . . . . . . . TEXT *SRCMBRTXT
    
    
    
    Mor
    F3=Exit F4=Prompt F5=Refresh F10=Additional parameters F12=Cancel
    F13=How to use this display F24=More keys
    Numeric value for parameter RCDLEN is not valid. 

  • #2
    This is the help I see under the RCDLEN parameter:

    Code:
    ................................................................
    :                Record length (RCDLEN) - Help                 :
    :                                                              :
    :  Specifies the length (in bytes) of the records stored in    :
    :  the physical file.  If RCDLEN and FILETYPE(*DATA) are       :
    :  specified, the physical file is created with a record       :
    :  format that has only one field.  The file is then           :
    :  restricted to an arrival sequence access path.  The record  :
    :  format and the field are both assigned the same name as     :
    :  that of the file, specified in the FILE parameter.  A       :
    :  value ranging from 1 through 32766 bytes can be specified   :
    :  for the record length.                                      :
    :                                                              :
    :                                                     More...  :
    :  F2=Extended help   F10=Move to top        F12=Cancel        :
    :  F13=Information Assistant   F20=Enlarge   F24=More keys     :
    :                                                              :
    :..............................................................:
    Since 32766 is explicitly listed as the maximum value, I can see why you wouldn't be able to specify values higher than 40000. This limitation has always been there from day one, we've never been able to specify a longer record length on the CRTPF command.

    Have you considered whether you can use a different style of file, such as a stream file?

    In my opinion, flat files are legacy cruft and should be avoided.

    Comment


    • gregwga50
      gregwga50 commented
      Editing a comment
      Thanks for responding.

      Just ignore my request. I just realized that it's the #of records I need to increase not the record length. I'll just chalk that one up to the fact it's Monday
Working...
X