Announcement

Collapse
No announcement yet.

Convert CLP to CLLE - getting 'Pointer not set...' on RMVMSG command

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Convert CLP to CLLE - getting 'Pointer not set...' on RMVMSG command

    Good Afternoon, thanks in advance for your help. I have an old CLP program that I converted to CLLE by changing the type in PDM. It compiled fine. When I ran the new CLLE I am getting 'Pointer not set for location referenced' on a RMVMSG command, set as follows: RMVMSG PGMQ(*SAME) CLEAR(*ALL) RMVEXCP(*YES) . When I comment the RMVMSG out I get the same error on a CHGDTAARA. Am I missing something?

  • #2
    How do you know the error is occurring on the RMVMSG/CHGDTAARA commands? Are you using debug to determine this? If so, are you sure you're calling the program you have just compiled or is another version of the program being called in different library? Errors that tend to move when you comment lines out like you describe often happen when the source doesn't match the program you are running.
    A "pointer not set" error is caused when the program tries to use a variable that has not been passed. Are you passing all the required parameters to the program?

    Comment


    • #3
      I am running the program in debug. After checking and double checking I am calling the program I compiled. There are no parameters being passed.

      After my initial post I found that if a Display File is using the 'DFT' keyword it could cause problems. I removed all the DFT keywords and used chgvar in the CLLE. The error is still happening, but after the SNDRCVF.

      Comment

      Working...
      X